Discuz “该函数需要 php.ini 中 allow_url_fopen

SJY发表于:2013年10月03日 20:30 • 阅读:

在安装Discuz2.5的时候提示“该函数需要 php.ini 中 allow_url_fopen 选项开启”,如果是虚拟主机,你就直接联系空间商,让他帮你解决,如果是自己的VPS,继续往下看。

fsockopen该函数需要 php.ini 中 allow_url_fopen 选项开启  

解决方法:

  1. php.ini文件中查找extension=php_openssl.dll 如果前面有分号,去掉分号。
  2. 在禁用函数disable_functions中找到fsockopen,删除,重启web服务。

不知道php.ini在哪?/usr/local/php/etc/目录下

不知道如何重启web服务?nginx重起命令  /etc/init.d/nginx restart

欢迎转载,但请保留原文地址 http://www.sjyhome.com/discuz/php-ini-allow_url_fopen.html.html

标签: 函数

回复(0)